What’s Vulnerable › Vulnerabilities
CVE-2024-22212: Nextcloud global site selector authentication bypass
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-18 · updated 2026-06-17
- Weakness: CWE-306
Description
Nextcloud Global Site Selector is a tool which allows you to run multiple small Nextcloud instances and redirect users to the right server. A problem in the password verification method allows an attacker to authenticate as another user. It is recommended that the Nextcloud Global Site Selector is upgraded to version 1.4.1, 2.1.2, 2.3.4 or 2.4.5. There are no known workarounds for this issue.
Affected products
- nextcloud Global Site Selector: from 1.1.0 before 1.4.1; from 2.0.0 before 2.1.2; from 2.2.0 before 2.3.4; from 2.4.0 before 2.4.5 — fixed in 1.4.1, 2.1.2, 2.3.4, 2.4.5
How to fix
Upgrade to a fixed version: nextcloud Global Site Selector 1.4.1, 2.1.2, 2.3.4, 2.4.5. Check the vendor advisory for mitigations.
References
- https://github.com/nextcloud/globalsiteselector/commit/ab5da57190d5bbc79079ce4109b6bcccccd893ee
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-vj5q-f63m-wp77
- https://hackerone.com/reports/2248689
- https://github.com/nextcloud/globalsiteselector/commit/ab5da57190d5bbc79079ce4109b6bcccccd893ee
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-vj5q-f63m-wp77
- https://hackerone.com/reports/2248689
Get alerted when CVE-2024-22212 or the next vulnerability affects your stack