What’s Vulnerable › Vulnerabilities
CVE-2024-22213: Cross-site Scripting when sending HTML as a comment in the Nextcloud Deck app
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-01-18 · updated 2026-06-17
- Weakness: CWE-79
Description
Deck is a kanban style organization tool aimed at personal planning and project organization for teams integrated with Nextcloud. In affected versions users could be tricked into executing malicious code that would execute in their browser via HTML sent as a comment. It is recommended that the Nextcloud Deck is upgraded to version 1.9.5 or 1.11.2. There are no known workarounds for this vulnerability.
Affected products
- Nextcloud Deck: from 1.9.0 before 1.9.5; from 1.10.0 before 1.11.2 — fixed in 1.11.2, 1.9.5
How to fix
Upgrade to a fixed version: Nextcloud Deck 1.11.2, 1.9.5. Check the vendor advisory for mitigations.
References
- https://github.com/nextcloud/deck/commit/91f1557362047f8840f53151f176b80148650bcd
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-mg7w-x9fm-9wwc
- https://hackerone.com/reports/2058556
- https://github.com/nextcloud/deck/commit/91f1557362047f8840f53151f176b80148650bcd
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-mg7w-x9fm-9wwc
- https://hackerone.com/reports/2058556
Get alerted when CVE-2024-22213 or the next vulnerability affects your stack