What’s Vulnerable › Vulnerabilities
CVE-2024-22217
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-15 · updated 2026-06-17
- Weakness: CWE-918
Description
A Server-Side Request Forgery (SSRF) vulnerability in Terminalfour before 8.3.19 allows authenticated users to use specific features to access internal services including sensitive information on the server that Terminalfour runs on.
Affected products
- Terminalfour: before 8.3.19 — fixed in 8.3.19
How to fix
Upgrade to a fixed version: Terminalfour 8.3.19. Check the vendor advisory for mitigations.
References
- https://docs.terminalfour.com/articles/release-notes-highlights/
- https://docs.terminalfour.com/release-notes/security-notices/cve-2024-22217/
Get alerted when CVE-2024-22217 or the next vulnerability affects your stack