What’s Vulnerable › Vulnerabilities
CVE-2024-22222
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-12 · updated 2026-06-17
- Weakness: CWE-78
Description
Dell Unity, versions prior to 5.4, contains an OS Command Injection Vulnerability within its svc_udoctor utility. An authenticated malicious user with local access could potentially exploit this vulnerability, leading to the execution of arbitrary OS commands on the application's underlying OS, with the privileges of the vulnerable application.
Affected products
- Dell Unity: before 5.4.0.0.5.094 — fixed in 5.4.0.0.5.094
How to fix
Upgrade to a fixed version: Dell Unity 5.4.0.0.5.094. Check the vendor advisory for mitigations.
References
- https://www.dell.com/support/kbdoc/en-us/000222010/dsa-2024-042-dell-unity-dell-unity-vsa-and-dell-unity-xt-security-update-for-multiple-vulnerabilities
- https://www.dell.com/support/kbdoc/en-us/000222010/dsa-2024-042-dell-unity-dell-unity-vsa-and-dell-unity-xt-security-update-for-multiple-vulnerabilities
Get alerted when CVE-2024-22222 or the next vulnerability affects your stack