What’s Vulnerable › Vulnerabilities
CVE-2024-22234: CVE-2024-22234: Broken Access Control in Spring Security With Direct Use of isFullyAuthenticated
- Severity: high (CVSS 7.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-20 · updated 2026-06-17
- Weakness: CWE-284
Description
In Spring Security, versions 6.1.x prior to 6.1.7 and versions 6.2.x prior to 6.2.2, an application is vulnerable to broken access control when it directly uses the AuthenticationTrustResolver.isFullyAuthenticated(Authentication) method. Specifically, an application is vulnerable if: * The application uses AuthenticationTrustResolver.isFullyAuthenticated(Authentication) directly and a null authentication parameter is passed to it resulting in an erroneous true return value. An application is not vulnerable if any of the following is true: * The application does not use AuthenticationTrustResolver.isFullyAuthenticated(Authentication) directly. * The application does not pass null to AuthenticationTrustResolver.isFullyAuthenticated * The application only uses isFullyAuthenticated via Method Security https://docs.spring.io/spring-security/reference/servlet/authorization/method-security.html or HTTP Request Security https://docs.spring.io/spring-security/reference/servlet/authorization/authorize-http-requests.html
Affected products
- Spring Security: from 6.1.0 before 6.1.7; from 6.2.0 before 6.2.2 — fixed in 6.1.7, 6.2.2
- Spring Security: from 6.1.0 before 6.1.7 — fixed in 6.1.7
- Spring Security: from 6.1.x before 6.1.7; from 6.2.x before 6.2.2 — fixed in 6.1.7, 6.2.2
How to fix
Upgrade to a fixed version: Spring Security 6.1.7, 6.2.2; Spring Security 6.1.7; Spring Security 6.1.7, 6.2.2. Check the vendor advisory for mitigations.
References
- https://security.netapp.com/advisory/ntap-20240315-0003/
- https://spring.io/security/cve-2024-22234
- https://security.netapp.com/advisory/ntap-20240315-0003/
- https://spring.io/security/cve-2024-22234
Get alerted when CVE-2024-22234 or the next vulnerability affects your stack