What’s Vulnerable › Vulnerabilities
CVE-2024-22235
- Severity: medium (CVSS 6.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-21 · updated 2026-06-17
- Weakness: CWE-269
Description
VMware Aria Operations contains a local privilege escalation vulnerability. A malicious actor with administrative access to the local system can escalate privileges to 'root'.
Affected products
- VMware Aria Operations: from 8.6.0 before 8.16.0 — fixed in 8.16.0
- VMware Cloud Foundation: from 4.0 through 5.2
- VMware Aria Operations: from 8.0 before 9.0 — fixed in 9.0
- VMware Aria Operations: VMware Aria Operations 8.x
How to fix
Upgrade to a fixed version: VMware Aria Operations 8.16.0; VMware Aria Operations 9.0. Check the vendor advisory for mitigations.
References
- https://www.vmware.com/security/advisories/VMSA-2024-0004.html
- https://www.vmware.com/security/advisories/VMSA-2024-0004.html
Get alerted when CVE-2024-22235 or the next vulnerability affects your stack