What’s Vulnerable › Vulnerabilities

CVE-2024-22236

Description

In Spring Cloud Contract, versions 4.1.x prior to 4.1.1, versions 4.0.x prior to 4.0.5, and versions 3.1.x prior to 3.1.10, test execution is vulnerable to local information disclosure via temporary directory created with unsafe permissions through the shaded com.google.guava:guava dependency in the org.springframework.cloud:spring-cloud-contract-shade dependency.

Affected products

How to fix

Upgrade to a fixed version: Spring Cloud Contract 3.1.10, 4.0.5; Spring Cloud Contract 4.1.1, 4.0.6, 3.1.10. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-22236 or the next vulnerability affects your stack