What’s Vulnerable › Vulnerabilities
CVE-2024-22254: Out-of-bounds write vulnerability
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-05 · updated 2026-06-17
- Weakness: CWE-787
Description
VMware ESXi contains an out-of-bounds write vulnerability. A malicious actor with privileges within the VMX process may trigger an out-of-bounds write leading to an escape of the sandbox.
Affected products
- VMware Cloud Foundation: from 4.0 through 5.0
- VMware ESXi: 7.0-update_1, 7.0-update_1a, 7.0-update_1b, 7.0-update_1c, 7.0-update_1d, 7.0-update_1e (+26); 7.0, 8.0
- Broadcom Vmware Cloud Foundation: 5.0, 4.0
- VMware ESXi: from 8.0 before ESXi80U2sb-23305545; from 8.0 before ESXi80U1d-23299997; from 7.0 before ESXi70U3p-23307199 — fixed in ESXi80U2sb-23305545, ESXi80U1d-23299997, ESXi70U3p-23307199
- VMware Cloud Foundation: 5.x, 4.x
- VMware ESXi: from 8.0 before ESXi80U2sb-23305545; from 8.0 before ESXi80U1d-23299997; from 7.0 before ESXi70U3p-23307199 — fixed in ESXi80U2sb-23305545, ESXi80U1d-23299997, ESXi70U3p-23307199
How to fix
Upgrade to a fixed version: VMware ESXi ESXi80U2sb-23305545, ESXi80U1d-23299997, ESXi70U3p-23307199; VMware ESXi ESXi80U2sb-23305545, ESXi80U1d-23299997, ESXi70U3p-23307199. Check the vendor advisory for mitigations.
References
- https://www.vmware.com/security/advisories/VMSA-2024-0006.html
- https://www.vmware.com/security/advisories/VMSA-2024-0006.html
Get alerted when CVE-2024-22254 or the next vulnerability affects your stack