What’s Vulnerable › Vulnerabilities

CVE-2024-22258: CVE-2024-22258: PKCE Downgrade in Spring Authorization Server

Description

Spring Authorization Server versions 1.0.0 - 1.0.5, 1.1.0 - 1.1.5, 1.2.0 - 1.2.2 and older unsupported versions are susceptible to a PKCE Downgrade Attack for Confidential Clients. Specifically, an application is vulnerable when a Confidential Client uses PKCE for the Authorization Code Grant. An application is not vulnerable when a Public Client uses PKCE for the Authorization Code Grant.

Affected products

How to fix

Upgrade to a fixed version: Spring 1.0.6, 1.1.6, 1.2.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-22258 or the next vulnerability affects your stack