What’s Vulnerable › Vulnerabilities
CVE-2024-22264: VMware Avi Load Balancer updates address multiple vulnerabilities
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-08 · updated 2026-06-17
- Weakness: CWE-269
Description
VMware Avi Load Balancer contains a privilege escalation vulnerability. A malicious actor with admin privileges on VMware Avi Load Balancer can create, modify, execute and delete files as a root user on the host system.
Affected products
- VMware Avi Load Balancer: 22.10.0, 30.0.0
- VMware Avi Load Balancer: from 22.1.x before 22.1.6; from 30.x.x before 30.2.1 — fixed in 22.1.6, 30.2.1
How to fix
Upgrade to a fixed version: VMware Avi Load Balancer 22.1.6, 30.2.1. Check the vendor advisory for mitigations.
References
- https://support.broadcom.com/web/ecx/support-content-notification/-/external/content/SecurityAdvisories/0/24219
- https://support.broadcom.com/web/ecx/support-content-notification/-/external/content/SecurityAdvisories/0/24219
Get alerted when CVE-2024-22264 or the next vulnerability affects your stack