What’s Vulnerable › Vulnerabilities
CVE-2024-22268
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-14 · updated 2026-06-17
- Weakness: CWE-787
Description
VMware Workstation and Fusion contain a heap buffer-overflow vulnerability in the Shader functionality. A malicious actor with non-administrative access to a virtual machine with 3D graphics enabled may be able to exploit this vulnerability to create a denial of service condition.
Affected products
- VMware Fusion: from 13.0.0 before 13.5.2 — fixed in 13.5.2
- VMware Workstation: from 17.0.0 before 17.5.2 — fixed in 17.5.2
- VMware Workstation: from 17.x before 17.5.2 — fixed in 17.5.2
How to fix
Upgrade to a fixed version: VMware Fusion 13.5.2; VMware Workstation 17.5.2; VMware Workstation 17.5.2. Check the vendor advisory for mitigations.
References
- https://support.broadcom.com/web/ecx/support-content-notification/-/external/content/SecurityAdvisories/0/24280
- https://support.broadcom.com/web/ecx/support-content-notification/-/external/content/SecurityAdvisories/0/24280
Get alerted when CVE-2024-22268 or the next vulnerability affects your stack