What’s Vulnerable › Vulnerabilities
CVE-2024-22274
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-21 · updated 2026-06-17
- Weakness: CWE-94
Description
The vCenter Server contains an authenticated remote code execution vulnerability. A malicious actor with administrative privileges on the vCenter appliance shell may exploit this issue to run arbitrary commands on the underlying operating system.
Affected products
- VMware Cloud Foundation: from 4.0 before 5.1.1 — fixed in 5.1.1
- VMware vCenter Server: 7.0, 7.0-a, 7.0-b, 7.0-c, 7.0-d, 7.0-update1 (+36)
- Broadcom Vmware Center Server: 8.0
- VMware Cloud Foundation (vCenter Server): from 5.x before 5.1.1; 4.x — fixed in 5.1.1
- VMware vCenter Server: from 8.0 before 8.0 U2b; from 7.0 before 7.0 U3q — fixed in 8.0 U2b, 7.0 U3q
How to fix
Upgrade to a fixed version: VMware Cloud Foundation 5.1.1; VMware Cloud Foundation (vCenter Server) 5.1.1; VMware vCenter Server 8.0 U2b, 7.0 U3q. Check the vendor advisory for mitigations.
References
- https://support.broadcom.com/web/ecx/support-content-notification/-/external/content/SecurityAdvisories/0/24308
- https://support.broadcom.com/web/ecx/support-content-notification/-/external/content/SecurityAdvisories/0/24308
Get alerted when CVE-2024-22274 or the next vulnerability affects your stack