What’s Vulnerable › Vulnerabilities
CVE-2024-22315: IBM Fusion improper communication restriction
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-28 · updated 2026-06-17
- Weakness: CWE-923
Description
IBM Fusion and IBM Fusion HCI 2.3.0 through 2.8.2 is vulnerable to insecure network connection by allowing an attacker who gains access to a Fusion container to establish an external network connection.
Affected products
- IBM Storage Fusion: from 2.3.0 before 2.9.0 — fixed in 2.9.0
- IBM Storage Fusion HCI: from 2.3.0 before 2.9.0 — fixed in 2.9.0
- IBM Storage Fusion Hci For Watsonx: 2.8.2
How to fix
Upgrade to a fixed version: IBM Storage Fusion 2.9.0; IBM Storage Fusion HCI 2.9.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-22315 or the next vulnerability affects your stack