What’s Vulnerable › Vulnerabilities
CVE-2024-22329: IBM WebSphere Application Server server-side request forgery
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-17 · updated 2026-06-17
- Weakness: CWE-918
Description
IBM WebSphere Application Server 8.5, 9.0 and IBM WebSphere Application Server Liberty 17.0.0.3 through 24.0.0.3 are vulnerable to server-side request forgery (SSRF). By sending a specially crafted request, an attacker could exploit this vulnerability to conduct the SSRF attack. X-Force ID: 279951.
Affected products
- IBM WebSphere Application Server: from 8.5.0.0 before 8.5.5.26; from 9.0.0.0 before 9.0.5.20; from 17.0.0.3 before 24.0.0.4 — fixed in 24.0.0.4, 8.5.5.26, 9.0.5.20
How to fix
Upgrade to a fixed version: IBM WebSphere Application Server 24.0.0.4, 8.5.5.26, 9.0.5.20. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/279951
- https://www.ibm.com/support/pages/node/7148380
- https://exchange.xforce.ibmcloud.com/vulnerabilities/279951
- https://www.ibm.com/support/pages/node/7148380
Get alerted when CVE-2024-22329 or the next vulnerability affects your stack