What’s Vulnerable › Vulnerabilities
CVE-2024-2234: Himer - Social Questions and Answers < 2.1.1 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-03 · updated 2026-06-17
- Weakness: CWE-79
Description
The Himer WordPress theme before 2.1.1 does not sanitise and escape some of its Post settings, which could allow high privilege users such as Contributor to perform Stored Cross-Site Scripting attacks
Affected products
- Himer: before 2.1.1 — fixed in 2.1.1
How to fix
Upgrade to a fixed version: Himer 2.1.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/37018a3f-895f-48f7-b033-c051e2462830/
- https://wpscan.com/vulnerability/37018a3f-895f-48f7-b033-c051e2462830/
Get alerted when CVE-2024-2234 or the next vulnerability affects your stack