What’s Vulnerable › Vulnerabilities
CVE-2024-22354: IBM WebSphere Application Server XML external entity injection
- Severity: high (CVSS 7.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-17 · updated 2026-06-17
- Weakness: CWE-611
Description
IBM WebSphere Application Server 8.5, 9.0 and IBM WebSphere Application Server Liberty 17.0.0.3 through 24.0.0.5 are vulnerable to an XML External Entity Injection (XXE) attack when processing XML data. A remote attacker could exploit this vulnerability to expose sensitive information, consume memory resources, or to conduct a server-side request forgery attack. IBM X-Force ID: 280401.
Affected products
- IBM WebSphere Application Server: from 8.5.0.0 before 8.5.5.26; from 9.0.0.0 before 9.0.5.20; from 17.0.0.3 before 24.0.0.6 — fixed in 24.0.0.6, 8.5.5.26, 9.0.5.20
How to fix
Upgrade to a fixed version: IBM WebSphere Application Server 24.0.0.6, 8.5.5.26, 9.0.5.20. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/280401
- https://www.ibm.com/support/pages/node/7148426
- https://exchange.xforce.ibmcloud.com/vulnerabilities/280401
- https://www.ibm.com/support/pages/node/7148426
Get alerted when CVE-2024-22354 or the next vulnerability affects your stack