What’s Vulnerable › Vulnerabilities

CVE-2024-22359: IBM UrbanCode Deploy cross-site scripting

Description

IBM UrbanCode Deploy (UCD) 7.0 through 7.0.5.20, 7.1 through 7.1.2.16, 7.2 through 7.2.3.9, 7.3 through 7.3.2.4 and IBM DevOps Deploy 8.0 through 8.0.0.1 are vulnerable to cross-site scripting. This vulnerability allows users to embed arbitrary JavaScript code in the Web UI thus altering the intended functionality potentially leading to credentials disclosure within a trusted session. IBM X-Force ID: 280897.

Affected products

How to fix

Upgrade to a fixed version: IBM DevOps Deploy 8.0.1.0; IBM UrbanCode Deploy 7.0.5.21, 7.1.2.17, 7.2.3.10, 7.3.2.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-22359 or the next vulnerability affects your stack