What’s Vulnerable › Vulnerabilities
CVE-2024-22361: IBM Semeru Runtime information disclosure
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-10 · updated 2026-06-17
- Weakness: CWE-327
Description
IBM Semeru Runtime 8.0.302.0 through 8.0.392.0, 11.0.12.0 through 11.0.21.0, 17.0.1.0 - 17.0.9.0, and 21.0.1.0 uses weaker than expected cryptographic algorithms that could allow an attacker to decrypt highly sensitive information. IBM X-Force ID: 281222.
Affected products
- IBM Semeru Runtime: from 8.0.302.0 before 8.0.402.0; from 11.0.12.0 before 11.0.22.0; from 17.0.1.0 before 17.0.10.0; 21.0.1.0 — fixed in 11.0.22.0, 17.0.10.0, 8.0.402.0
How to fix
Upgrade to a fixed version: IBM Semeru Runtime 11.0.22.0, 17.0.10.0, 8.0.402.0. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/281222
- https://www.ibm.com/support/pages/node/7116431
- https://exchange.xforce.ibmcloud.com/vulnerabilities/281222
- https://www.ibm.com/support/pages/node/7116431
Get alerted when CVE-2024-22361 or the next vulnerability affects your stack