What’s Vulnerable › Vulnerabilities
CVE-2024-22365
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-02-06 · updated 2026-10-15
- Weakness: CWE-664
Description
linux-pam (aka Linux PAM) before 1.6.0 allows attackers to cause a denial of service (blocked login process) via mkfifo because the openat call (for protect_dir) lacks O_DIRECTORY.
Affected products
- Linux-PAM: before 1.6.0 — fixed in 1.6.0
How to fix
Upgrade to a fixed version: Linux-PAM 1.6.0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2024/01/18/3
- https://github.com/linux-pam/linux-pam
- https://github.com/linux-pam/linux-pam/commit/031bb5a5d0d950253b68138b498dc93be69a64cb
- https://github.com/linux-pam/linux-pam/releases/tag/v1.6.0
- http://www.openwall.com/lists/oss-security/2024/01/18/3
- https://github.com/linux-pam/linux-pam
- https://github.com/linux-pam/linux-pam/commit/031bb5a5d0d950253b68138b498dc93be69a64cb
- https://github.com/linux-pam/linux-pam/releases/tag/v1.6.0
- https://lists.debian.org/debian-lts-announce/2025/09/msg00021.html
- https://cert-portal.siemens.com/productcert/html/ssa-577017.html
- https://cert-portal.siemens.com/productcert/html/ssa-794697.html
Get alerted when CVE-2024-22365 or the next vulnerability affects your stack