What’s Vulnerable › Vulnerabilities

CVE-2024-22369: Apache Camel: Camel-SQL: Unsafe Deserialization from JDBCAggregationRepository

Description

Deserialization of Untrusted Data vulnerability in Apache Camel SQL ComponentThis issue affects Apache Camel: from 3.0.0 before 3.21.4, from 3.22.0 before 3.22.1, from 4.0.0 before 4.0.4, from 4.1.0 before 4.4.0. Users are recommended to upgrade to version 4.4.0, which fixes the issue. If users are on the 4.0.x LTS releases stream, then they are suggested to upgrade to 4.0.4. If users are on 3.x, they are suggested to move to 3.21.4 or 3.22.1

Affected products

How to fix

Upgrade to a fixed version: Apache Software Foundation Apache Camel 3.21.4, 4.0.4, 4.4.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-22369 or the next vulnerability affects your stack