What’s Vulnerable › Vulnerabilities
CVE-2024-22371: Apache Camel issue on ExchangeCreatedEvent
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-26 · updated 2026-06-17
- Weakness: CWE-922
Description
Exposure of sensitive data by by crafting a malicious EventFactory and providing a custom ExchangeCreatedEvent that exposes sensitive data. Vulnerability in Apache Camel.This issue affects Apache Camel: from 3.21.X through 3.21.3, from 3.22.X through 3.22.0, from 4.0.X through 4.0.3, from 4.X through 4.3.0. Users are recommended to upgrade to version 3.21.4, 3.22.1, 4.0.4 or 4.4.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache Camel: from 3.0.0 before 3.21.4; from 4.0.0 before 4.0.4; from 4.1.0 before 4.4.0; 3.22.0 — fixed in 3.21.4, 4.0.4, 4.4.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Camel 3.21.4, 4.0.4, 4.4.0. Check the vendor advisory for mitigations.
References
- https://camel.apache.org/security/CVE-2024-22371.html
- https://camel.apache.org/security/CVE-2024-22371.html
Get alerted when CVE-2024-22371 or the next vulnerability affects your stack