What’s Vulnerable › Vulnerabilities
CVE-2024-2239: Premium Addons PRO <= 2.9.12 - Authenticated (Contributor+) Stored Cross-Site Scripting via Premium Magic Scroll Module
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The Premium Addons PRO plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Premium Magic Scroll module in all versions up to, and including, 2.9.12 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- Premium Addons for Elementor Premium Addons Pro for Elementor: before 2.9.13 — fixed in 2.9.13
How to fix
Upgrade to a fixed version: Premium Addons for Elementor Premium Addons Pro for Elementor 2.9.13. Check the vendor advisory for mitigations.
References
- https://premiumaddons.com/change-log/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/254f3a1c-0d5d-499b-9da7-129f21ba70af?source=cve
- https://premiumaddons.com/change-log/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/254f3a1c-0d5d-499b-9da7-129f21ba70af?source=cve
Get alerted when CVE-2024-2239 or the next vulnerability affects your stack