What’s Vulnerable › Vulnerabilities
CVE-2024-22400: Open redirect in user_saml via RelayState parameter in Nextcloud User Saml
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-18 · updated 2026-06-17
- Weakness: CWE-601
Description
Nextcloud User Saml is an app for authenticating Nextcloud users using SAML. In affected versions users can be given a link to the Nextcloud server and end up on a uncontrolled thirdparty server. It is recommended that the User Saml app is upgraded to version 5.1.5, 5.2.5, or 6.0.1. There are no known workarounds for this issue.
Affected products
- nextcloud Sso & Saml Authentication: from 5.0.0 before 5.1.5; from 5.2.0 before 5.2.5; 6.0.0 — fixed in 5.1.5, 5.2.5
How to fix
Upgrade to a fixed version: nextcloud Sso & Saml Authentication 5.1.5, 5.2.5. Check the vendor advisory for mitigations.
References
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-622q-xhfr-xmv7
- https://github.com/nextcloud/user_saml/commit/b184304a476deeba36e92b70562d5de7c2f85f8a
- https://github.com/nextcloud/user_saml/pull/788
- https://hackerone.com/reports/2263044
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-622q-xhfr-xmv7
- https://github.com/nextcloud/user_saml/commit/b184304a476deeba36e92b70562d5de7c2f85f8a
- https://github.com/nextcloud/user_saml/pull/788
- https://hackerone.com/reports/2263044
Get alerted when CVE-2024-22400 or the next vulnerability affects your stack