What’s Vulnerable › Vulnerabilities
CVE-2024-22407: Broken Access Control order API in Shopware
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-16 · updated 2026-06-17
- Weakness: CWE-284
Description
Shopware is an open headless commerce platform. In the Shopware CMS, the state handler for orders fails to sufficiently verify user authorizations for actions that modify the payment, delivery, and/or order status. Due to this inadequate implementation, users lacking 'write' permissions for orders are still able to change the order state. This issue has been addressed and users are advised to update to Shopware 6.5.7.4. For older versions of 6.1, 6.2, 6.3 and 6.4 corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version.
Affected products
- shopware: before 6.5.7.4 — fixed in 6.5.7.4
How to fix
Upgrade to a fixed version: shopware 6.5.7.4. Check the vendor advisory for mitigations.
References
- https://github.com/shopware/shopware/security/advisories/GHSA-3867-jc5c-66qf
- https://github.com/shopware/shopware/security/advisories/GHSA-3867-jc5c-66qf
Get alerted when CVE-2024-22407 or the next vulnerability affects your stack