What’s Vulnerable › Vulnerabilities
CVE-2024-22408: Server-Side Request Forgery (SSRF) in Shopware Flow Builder
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-16 · updated 2026-06-17
- Weakness: CWE-918
Description
Shopware is an open headless commerce platform. The implemented Flow Builder functionality in the Shopware application does not adequately validate the URL used when creating the “call webhook” action. This enables malicious users to perform web requests to internal hosts. This issue has been fixed in the Commercial Plugin release 6.5.7.4 or with the Security Plugin. For installations with Shopware 6.4 the Security plugin is recommended to be installed and up to date. For older versions of 6.4 and 6.5 corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version.
Affected products
- shopware: before 6.5.7.4 — fixed in 6.5.7.4
How to fix
Upgrade to a fixed version: shopware 6.5.7.4. Check the vendor advisory for mitigations.
References
- https://github.com/shopware/shopware/security/advisories/GHSA-3535-m8vh-vrmw
- https://github.com/shopware/shopware/security/advisories/GHSA-3535-m8vh-vrmw
Get alerted when CVE-2024-22408 or the next vulnerability affects your stack