What’s Vulnerable › Vulnerabilities
CVE-2024-22409: Default Privileges allow for high level operations for low privileged users in datahub
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-01-16 · updated 2026-06-17
- Weakness: CWE-276
Description
DataHub is an open-source metadata platform. In affected versions a low privileged user could remove a user, edit group members, or edit another user's profile information. The default privileges gave too many broad permissions to low privileged users. These have been constrained in PR #9067 to prevent abuse. This issue can result in privilege escalation for lower privileged users up to admin privileges, potentially, if a group with admin privileges exists. May not impact instances that have modified default privileges. This issue has been addressed in datahub version 0.12.1. Users are advised to upgrade.
Affected products
- Datahub Project Datahub: before 0.12.1 — fixed in 0.12.1
How to fix
Upgrade to a fixed version: Datahub Project Datahub 0.12.1. Check the vendor advisory for mitigations.
References
- https://github.com/datahub-project/datahub/pull/9067
- https://github.com/datahub-project/datahub/security/advisories/GHSA-x3v6-r479-m4xv
- https://github.com/datahub-project/datahub/pull/9067
- https://github.com/datahub-project/datahub/security/advisories/GHSA-x3v6-r479-m4xv
Get alerted when CVE-2024-22409 or the next vulnerability affects your stack