What’s Vulnerable › Vulnerabilities
CVE-2024-22416: Cross-Site Request Forgery on any API call in pyLoad may lead to admin privilege escalation
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-01-18 · updated 2026-06-17
- Weakness: CWE-352
Description
pyLoad is a free and open-source Download Manager written in pure Python. The `pyload` API allows any API call to be made using GET requests. Since the session cookie is not set to `SameSite: strict`, this opens the library up to severe attack possibilities via a Cross-Site Request Forgery (CSRF) attack. As a result any API call can be made via a CSRF attack by an unauthenticated user. This issue has been addressed in release `0.5.0b3.dev78`. All users are advised to upgrade.
Affected products
- pyload: before 0.5.0b3.dev78 — fixed in 0.5.0b3.dev78
How to fix
Upgrade to a fixed version: pyload 0.5.0b3.dev78. Check the vendor advisory for mitigations.
References
- https://github.com/pyload/pyload/commit/1374c824271cb7e927740664d06d2e577624ca3e
- https://github.com/pyload/pyload/commit/c7cdc18ad9134a75222974b39e8b427c4af845fc
- https://github.com/pyload/pyload/security/advisories/GHSA-pgpj-v85q-h5fm
- https://github.com/pyload/pyload/commit/1374c824271cb7e927740664d06d2e577624ca3e
- https://github.com/pyload/pyload/commit/c7cdc18ad9134a75222974b39e8b427c4af845fc
- https://github.com/pyload/pyload/security/advisories/GHSA-pgpj-v85q-h5fm
Get alerted when CVE-2024-22416 or the next vulnerability affects your stack