What’s Vulnerable › Vulnerabilities
CVE-2024-22418: Stored Cross-site Scripting Vulnerability via Malicious File Names in GroupOffice
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-01-18 · updated 2026-06-17
- Weakness: CWE-79
Description
Group-Office is an enterprise CRM and groupware tool. Affected versions are subject to a vulnerability which is present in the file upload mechanism of Group Office. It allows an attacker to execute arbitrary JavaScript code by embedding it within a file's name. For instance, using a filename such as “><img src=x onerror=prompt('XSS')>.jpg” triggers the vulnerability. When this file is uploaded, the JavaScript code within the filename is executed. This issue has been addressed in version 6.8.29. All users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- Intermesh groupoffice: before 6.8.29 — fixed in 6.8.29
How to fix
Upgrade to a fixed version: Intermesh groupoffice 6.8.29. Check the vendor advisory for mitigations.
References
- https://github.com/Intermesh/groupoffice/commit/2a52a5d42d080db6738d70eba30294bcd94ebd09
- https://github.com/Intermesh/groupoffice/security/advisories/GHSA-p7w9-h6c3-wqpp
- https://github.com/Intermesh/groupoffice/commit/2a52a5d42d080db6738d70eba30294bcd94ebd09
- https://github.com/Intermesh/groupoffice/security/advisories/GHSA-p7w9-h6c3-wqpp
Get alerted when CVE-2024-22418 or the next vulnerability affects your stack