What’s Vulnerable › Vulnerabilities
CVE-2024-22451
- Severity: medium (CVSS 6.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-16 · updated 2026-10-02
- Weakness: CWE-427
Description
Dell Peripheral Manager, versions from 1.5.1 to 1.7.2, contain an uncontrolled search path element vulnerability. An attacker could potentially exploit this vulnerability through preloading malicious executable, leading to arbitrary code execution.
Affected products
- Dell Peripheral Manager: from 1.5.1 before 1.7.3 — fixed in 1.7.3
How to fix
Upgrade to a fixed version: Dell Peripheral Manager 1.7.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-22451 or the next vulnerability affects your stack