What’s Vulnerable › Vulnerabilities
CVE-2024-22452
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-04 · updated 2026-06-17
- Weakness: CWE-264
Description
Dell Display and Peripheral Manager for macOS prior to 1.3 contains an improper access control vulnerability. A low privilege user could potentially exploit this vulnerability by modifying files in the installation folder to execute arbitrary code, leading to privilege escalation.
Affected products
- Dell Display and Peripheral Manager: before 1.3 — fixed in 1.3
How to fix
Upgrade to a fixed version: Dell Display and Peripheral Manager 1.3. Check the vendor advisory for mitigations.
References
- https://www.dell.com/support/kbdoc/en-us/000221414/dsa-2024-056
- https://www.dell.com/support/kbdoc/en-us/000221414/dsa-2024-056
Get alerted when CVE-2024-22452 or the next vulnerability affects your stack