What’s Vulnerable › Vulnerabilities
CVE-2024-22459
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-28 · updated 2026-06-17
- Weakness: CWE-284
Description
Dell ECS, versions 3.6 through 3.6.2.5, and 3.7 through 3.7.0.6, and 3.8 through 3.8.0.4 versions, contain an improper access control vulnerability. A remote high privileged attacker could potentially exploit this vulnerability, leading to unauthorized access to all buckets and their data within a namespace
Affected products
- EMC Elastic Cloud Storage all versions prior to 3.1: from 3.6.0.0 before 3.6.2.6; from 3.7.0.0 before 3.7.0.7; from 3.8.0.0 before 3.8.0.5 — fixed in 3.6.2.6, 3.7.0.7, 3.8.0.5
How to fix
Upgrade to a fixed version: EMC Elastic Cloud Storage all versions prior to 3.1 3.6.2.6, 3.7.0.7, 3.8.0.5. Check the vendor advisory for mitigations.
References
- https://www.dell.com/support/kbdoc/en-us/000222470/dsa-2024-078-security-update-for-dell-ecs-access-control-vulnerability
- https://www.dell.com/support/kbdoc/en-us/000222470/dsa-2024-078-security-update-for-dell-ecs-access-control-vulnerability
Get alerted when CVE-2024-22459 or the next vulnerability affects your stack