What’s Vulnerable › Vulnerabilities
CVE-2024-22725
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-24 · updated 2026-06-17
- Weakness: CWE-79
Description
Orthanc versions before 1.12.2 are affected by a reflected cross-site scripting (XSS) vulnerability. The vulnerability was present in the server's error reporting.
Affected products
- orthanc-server orthanc: before 1.12.2 — fixed in 1.12.2
How to fix
Upgrade to a fixed version: orthanc-server orthanc 1.12.2. Check the vendor advisory for mitigations.
References
- https://orthanc.uclouvain.be/hg/orthanc/file/Orthanc-1.12.2/NEWS
- https://orthanc.uclouvain.be/hg/orthanc/rev/505416b269a0
- https://orthanc.uclouvain.be/hg/orthanc/file/Orthanc-1.12.2/NEWS
- https://orthanc.uclouvain.be/hg/orthanc/rev/505416b269a0
Get alerted when CVE-2024-22725 or the next vulnerability affects your stack