What’s Vulnerable › Vulnerabilities
CVE-2024-2280: Better Elementor Addons <= 1.4.1 - Authenticated(Contributor+) Stored Cross-Site Scripting via widget links
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-29 · updated 2026-06-17
- Weakness: CWE-79
Description
The Better Elementor Addons plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the widget link URL values in all versions up to, and including, 1.4.1 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- wpdive Better Addons for Elementor: before 1.4.2 — fixed in 1.4.2
How to fix
Upgrade to a fixed version: wpdive Better Addons for Elementor 1.4.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3060565%40better-elementor-addons&new=3060565%40better-elementor-addons&sfp_email=&sfph_mail=
- https://wordpress.org/plugins/better-elementor-addons/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/e8d7ace3-af34-4951-810b-87923ef2ec30?source=cve
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3060565%40better-elementor-addons&new=3060565%40better-elementor-addons&sfp_email=&sfph_mail=
- https://wordpress.org/plugins/better-elementor-addons/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/e8d7ace3-af34-4951-810b-87923ef2ec30?source=cve
Get alerted when CVE-2024-2280 or the next vulnerability affects your stack