What’s Vulnerable › Vulnerabilities
CVE-2024-22910
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-14 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross Site Scripting (XSS) vulnerability in CrushFTP v.10.6.0 and v.10.5.5 allows an attacker to execute arbitrary code via a crafted payload.
Affected products
- CrushFTP: before 10.6.1 — fixed in 10.6.1
How to fix
Upgrade to a fixed version: CrushFTP 10.6.1. Check the vendor advisory for mitigations.
References
- https://gist.github.com/cgnl/672ace3cbad1116fcd9ae633e54ea9f8
- https://gist.github.com/cgnl/672ace3cbad1116fcd9ae633e54ea9f8
Get alerted when CVE-2024-22910 or the next vulnerability affects your stack