What’s Vulnerable › Vulnerabilities
CVE-2024-2309: WP Staging < 3.4.0, 5.4.0 (Pro Version) - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-04-17 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP STAGING WordPress Backup Plugin WordPress plugin before 3.4.0, wp-staging-pro WordPress plugin before 5.4.0 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Affected products
- WP STAGING WordPress Backup Plugin: before 3.4.0 — fixed in 3.4.0
How to fix
Upgrade to a fixed version: WP STAGING WordPress Backup Plugin 3.4.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/a4152818-1e07-46a7-aec4-70f1a1b579a6/
- https://wpscan.com/vulnerability/a4152818-1e07-46a7-aec4-70f1a1b579a6/
Get alerted when CVE-2024-2309 or the next vulnerability affects your stack