What’s Vulnerable › Vulnerabilities
CVE-2024-23107
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-03 · updated 2026-06-17
- Weakness: CWE-200
Description
An exposure of sensitive information to an unauthorized actor vulnerability [CWE-200] in FortiWeb version 7.4.0, version 7.2.4 and below, version 7.0.8 and below, 6.3 all versions may allow an authenticated attacker to read password hashes of other administrators via CLI commands.
Affected products
- Fortinet FortiWeb: from 6.3.0 through 6.3.23; from 7.0.0 before 7.0.9; from 7.2.0 before 7.2.5; 7.4.0 — fixed in 7.0.9, 7.2.5
How to fix
Upgrade to a fixed version: Fortinet FortiWeb 7.0.9, 7.2.5. Check the vendor advisory for mitigations.
References
- https://fortiguard.fortinet.com/psirt/FG-IR-23-191
- https://fortiguard.fortinet.com/psirt/FG-IR-23-191
Get alerted when CVE-2024-23107 or the next vulnerability affects your stack