What’s Vulnerable › Vulnerabilities
CVE-2024-23110
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-11 · updated 2026-06-17
- Weakness: CWE-121
Description
A stack-based buffer overflow in Fortinet FortiOS version 7.4.0 through 7.4.2, 7.2.0 through 7.2.6, 7.0.0 through 7.0.13, 6.4.0 through 6.4.14, 6.2.0 through 6.2.15, 6.0 all versions allows attacker to execute unauthorized code or commands via specially crafted commands
Affected products
- Fortinet FortiOS (FortiGate): from 6.0.0 before 6.2.16; from 6.4.0 before 6.4.15; from 7.0.0 before 7.0.14; from 7.2.0 before 7.2.7; from 7.4.0 before 7.4.3 — fixed in 6.2.16, 6.4.15, 7.0.14, 7.2.7, 7.4.3
How to fix
Upgrade to a fixed version: Fortinet FortiOS (FortiGate) 6.2.16, 6.4.15, 7.0.14, 7.2.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-23110 or the next vulnerability affects your stack