What’s Vulnerable › Vulnerabilities

CVE-2024-23111

Description

An improper neutralization of input during web page Generation ('Cross-site Scripting') vulnerability [CWE-79] in FortiOS version 7.4.3 and below, 7.2 all versions, 7.0 all versions and FortiProxy version 7.4.2 and below, 7.2 all versions, 7.0 all versions reboot page may allow a remote privileged attacker with super-admin access to execute JavaScript code via crafted HTTP GET requests.

Affected products

How to fix

Upgrade to a fixed version: Fortinet FortiOS (FortiGate) 7.0.14, 7.2.8, 7.4.4; Fortinet FortiProxy 7.0.15, 7.2.9, 7.4.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-23111 or the next vulnerability affects your stack