What’s Vulnerable › Vulnerabilities
CVE-2024-23171
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-01-12 · updated 2026-06-17
- Weakness: CWE-79
Description
An issue was discovered in the CampaignEvents extension in MediaWiki before 1.35.14, 1.36.x through 1.39.x before 1.39.6, and 1.40.x before 1.40.2. The Special:EventDetails page allows XSS via the x-xss language setting for internationalization (i18n).
Affected products
- Wikimedia Foundation MediaWiki: before 1.35.14; from 1.36.0 before 1.39.6; from 1.40.0 before 1.40.2 — fixed in 1.35.14, 1.39.6, 1.40.2
How to fix
Upgrade to a fixed version: Wikimedia Foundation MediaWiki 1.35.14, 1.39.6, 1.40.2. Check the vendor advisory for mitigations.
References
- https://gerrit.wikimedia.org/r/q/I70d71c409193e904684dfb706d424b0a815fa6f6
- https://phabricator.wikimedia.org/T348343
- https://gerrit.wikimedia.org/r/q/I70d71c409193e904684dfb706d424b0a815fa6f6
- https://phabricator.wikimedia.org/T348343
Get alerted when CVE-2024-23171 or the next vulnerability affects your stack