What’s Vulnerable › Vulnerabilities
CVE-2024-23172
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-01-12 · updated 2026-06-17
- Weakness: CWE-79
Description
An issue was discovered in the CheckUser extension in MediaWiki before 1.35.14, 1.36.x through 1.39.x before 1.39.6, and 1.40.x before 1.40.2. XSS can occur via message definitions. e.g., in SpecialCheckUserLog.
Affected products
- Wikimedia Foundation MediaWiki: before 1.35.14; from 1.36.0 before 1.39.6; from 1.40.0 before 1.40.2 — fixed in 1.35.14, 1.39.6, 1.40.2
How to fix
Upgrade to a fixed version: Wikimedia Foundation MediaWiki 1.35.14, 1.39.6, 1.40.2. Check the vendor advisory for mitigations.
References
- https://gerrit.wikimedia.org/r/c/mediawiki/extensions/CheckUser/+/989179
- https://phabricator.wikimedia.org/T347708
- https://gerrit.wikimedia.org/r/c/mediawiki/extensions/CheckUser/+/989179
- https://phabricator.wikimedia.org/T347708
Get alerted when CVE-2024-23172 or the next vulnerability affects your stack