What’s Vulnerable › Vulnerabilities
CVE-2024-23178
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-01-12 · updated 2026-06-17
- Weakness: CWE-79
Description
An issue was discovered in the Phonos extension in MediaWiki before 1.40.2. PhonosButton.js allows i18n-based XSS via the phonos-purge-needed-error message.
Affected products
- Wikimedia Foundation MediaWiki: before 1.40.2 — fixed in 1.40.2
How to fix
Upgrade to a fixed version: Wikimedia Foundation MediaWiki 1.40.2. Check the vendor advisory for mitigations.
References
- https://lists.wikimedia.org/hyperkitty/list/mediawiki-announce%40lists.wikimedia.org/message/TDBUBCCOQJUT4SCHJNPHKQNPBUUETY52/
- https://phabricator.wikimedia.org/T349312
- https://lists.wikimedia.org/hyperkitty/list/mediawiki-announce%40lists.wikimedia.org/message/TDBUBCCOQJUT4SCHJNPHKQNPBUUETY52/
- https://phabricator.wikimedia.org/T349312
Get alerted when CVE-2024-23178 or the next vulnerability affects your stack