What’s Vulnerable › Vulnerabilities
CVE-2024-23180
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-23 · updated 2026-06-17
- Weakness: CWE-434
Description
Improper input validation vulnerability in a-blog cms Ver.3.1.x series versions prior to Ver.3.1.7, Ver.3.0.x series versions prior to Ver.3.0.29, Ver.2.11.x series versions prior to Ver.2.11.58, Ver.2.10.x series versions prior to Ver.2.10.50, and Ver.2.9.0 and earlier allows a remote authenticated attacker to execute arbitrary code by uploading a specially crafted SVG file.
Affected products
- appleple inc. a-blog cms: through 2.9.0; from 2.10.0 before 2.10.50; from 2.11.0 before 2.11.58; from 3.0.0 before 3.0.29; from 3.1.0 before 3.1.7 — fixed in 2.10.50, 2.11.58, 3.0.29, 3.1.7
How to fix
Upgrade to a fixed version: appleple inc. a-blog cms 2.10.50, 2.11.58, 3.0.29, 3.1.7. Check the vendor advisory for mitigations.
References
- https://developer.a-blogcms.jp/blog/news/JVN-34565930.html
- https://jvn.jp/en/jp/JVN34565930/
- https://developer.a-blogcms.jp/blog/news/JVN-34565930.html
- https://jvn.jp/en/jp/JVN34565930/
Get alerted when CVE-2024-23180 or the next vulnerability affects your stack