What’s Vulnerable › Vulnerabilities
CVE-2024-23274
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-08 · updated 2026-06-17
- Weakness: CWE-74
Description
An injection issue was addressed with improved input validation. This issue is fixed in macOS Monterey 12.7.4, macOS Sonoma 14.4, macOS Ventura 13.6.5. An app may be able to elevate privileges.
Affected products
- Apple macOS: from 12.0.0 before 12.7.4; from 13.0 before 13.6.5; from 14.0 before 14.4 — fixed in 12.7.4, 13.6.5, 14.4
How to fix
Upgrade to a fixed version: Apple macOS 12.7.4, 13.6.5, 14.4. Check the vendor advisory for mitigations.
References
- https://support.apple.com/en-us/120884
- https://support.apple.com/en-us/120886
- https://support.apple.com/en-us/120895
- http://seclists.org/fulldisclosure/2024/Mar/21
- http://seclists.org/fulldisclosure/2024/Mar/22
- http://seclists.org/fulldisclosure/2024/Mar/23
- https://support.apple.com/en-us/HT214083
- https://support.apple.com/en-us/HT214084
- https://support.apple.com/en-us/HT214085
- https://support.apple.com/kb/HT214083
- https://support.apple.com/kb/HT214084
- https://support.apple.com/kb/HT214085
Get alerted when CVE-2024-23274 or the next vulnerability affects your stack