What’s Vulnerable › Vulnerabilities
CVE-2024-23307: Integer overflow in raid5_cache_count in Linux kernel
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-25 · updated 2026-10-15
- Weakness: CWE-190
Description
Integer Overflow or Wraparound vulnerability in Linux Linux kernel kernel on Linux, x86, ARM (md, raid, raid5 modules) allows Forced Integer Overflow.
Affected products
- Linux kernel: from 4.1 before 6.1.84; from 6.2 before 6.6.24; from 6.7 before 6.7.12; from 6.8 before 6.8.3 — fixed in 6.1.84, 6.6.24, 6.7.12, 6.8.3
How to fix
Upgrade to a fixed version: Linux kernel 6.1.84, 6.6.24, 6.7.12, 6.8.3. Check the vendor advisory for mitigations.
References
- https://bugzilla.openanolis.cn/show_bug.cgi?id=7975
- https://bugzilla.openanolis.cn/show_bug.cgi?id=7975
- https://cert-portal.siemens.com/productcert/html/ssa-265688.html
Get alerted when CVE-2024-23307 or the next vulnerability affects your stack