What’s Vulnerable › Vulnerabilities
CVE-2024-23320: Apache DolphinScheduler: Arbitrary js execution as root for authenticated users
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-23 · updated 2026-06-17
- Weakness: CWE-20
Description
Improper Input Validation vulnerability in Apache DolphinScheduler. An authenticated user can cause arbitrary, unsandboxed javascript to be executed on the server. This issue is a legacy of CVE-2023-49299. We didn't fix it completely in CVE-2023-49299, and we added one more patch to fix it. This issue affects Apache DolphinScheduler: until 3.2.1. Users are recommended to upgrade to version 3.2.1, which fixes the issue.
Affected products
- Apache Software Foundation Apache DolphinScheduler: before 3.2.1 — fixed in 3.2.1
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache DolphinScheduler 3.2.1. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2024/02/23/3
- https://github.com/apache/dolphinscheduler/pull/15487
- https://lists.apache.org/thread/25qhfvlksozzp6j9y8ozznvjdjp3lxqq
- https://lists.apache.org/thread/p7rwzdgrztdfps8x1bwx646f1mn0x6cp
- https://lists.apache.org/thread/tnf99qoc6tlnwrny4t1zk6mfszgdsokm
- http://www.openwall.com/lists/oss-security/2024/02/23/3
- https://github.com/apache/dolphinscheduler/pull/15487
- https://lists.apache.org/thread/25qhfvlksozzp6j9y8ozznvjdjp3lxqq
- https://lists.apache.org/thread/p7rwzdgrztdfps8x1bwx646f1mn0x6cp
- https://lists.apache.org/thread/tnf99qoc6tlnwrny4t1zk6mfszgdsokm
Get alerted when CVE-2024-23320 or the next vulnerability affects your stack