What’s Vulnerable › Vulnerabilities
CVE-2024-23324: Envoy ext auth can be bypassed when Proxy protocol filter sets invalid UTF-8 metadata
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-09 · updated 2026-06-17
- Weakness: CWE-20
Description
Envoy is a high-performance edge/middle/service proxy. External authentication can be bypassed by downstream connections. Downstream clients can force invalid gRPC requests to be sent to ext_authz, circumventing ext_authz checks when failure_mode_allow is set to true. This issue has been addressed in released 1.29.1, 1.28.1, 1.27.3, and 1.26.7. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- envoyproxy envoy: from 1.26.0 before 1.26.7; from 1.27.0 before 1.27.3; from 1.28.0 before 1.28.1; from 1.29.0 before 1.29.1 — fixed in 1.26.7, 1.27.3, 1.28.1, 1.29.1
How to fix
Upgrade to a fixed version: envoyproxy envoy 1.26.7, 1.27.3, 1.28.1, 1.29.1. Check the vendor advisory for mitigations.
References
- https://github.com/envoyproxy/envoy/commit/29989f6cc8bfd8cd2ffcb7c42711eb02c7a5168a
- https://github.com/envoyproxy/envoy/security/advisories/GHSA-gq3v-vvhj-96j6
- https://github.com/envoyproxy/envoy/commit/29989f6cc8bfd8cd2ffcb7c42711eb02c7a5168a
- https://github.com/envoyproxy/envoy/security/advisories/GHSA-gq3v-vvhj-96j6
Get alerted when CVE-2024-23324 or the next vulnerability affects your stack