What’s Vulnerable › Vulnerabilities
CVE-2024-23326: Envoy incorrectly accepts HTTP 200 response for entering upgrade mode
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-04 · updated 2026-06-17
- Weakness: CWE-391
Description
Envoy is a cloud-native, open source edge and service proxy. A theoretical request smuggling vulnerability exists through Envoy if a server can be tricked into adding an upgrade header into a response. Per RFC https://www.rfc-editor.org/rfc/rfc7230#section-6.7 a server sends 101 when switching protocols. Envoy incorrectly accepts a 200 response from a server when requesting a protocol upgrade, but 200 does not indicate protocol switch. This opens up the possibility of request smuggling through Envoy if the server can be tricked into adding the upgrade header to the response.
Affected products
- envoyproxy envoy: before 1.27.6; from 1.28.0 before 1.28.4; from 1.29.0 before 1.29.5; from 1.30.0 before 1.30.2 — fixed in 1.27.6, 1.28.4, 1.29.5, 1.30.2
How to fix
Upgrade to a fixed version: envoyproxy envoy 1.27.6, 1.28.4, 1.29.5, 1.30.2. Check the vendor advisory for mitigations.
References
- https://github.com/envoyproxy/envoy/security/advisories/GHSA-vcf8-7238-v74c
- https://github.com/envoyproxy/envoy/security/advisories/GHSA-vcf8-7238-v74c
Get alerted when CVE-2024-23326 or the next vulnerability affects your stack