What’s Vulnerable › Vulnerabilities
CVE-2024-23327: Crash in proxy protocol when command type of LOCAL in Envoy
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-09 · updated 2026-06-17
- Weakness: CWE-476
Description
Envoy is a high-performance edge/middle/service proxy. When PPv2 is enabled both on a listener and subsequent cluster, the Envoy instance will segfault when attempting to craft the upstream PPv2 header. This occurs when the downstream request has a command type of LOCAL and does not have the protocol block. This issue has been addressed in releases 1.29.1, 1.28.1, 1.27.3, and 1.26.7. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- envoyproxy envoy: from 1.26.0 before 1.26.7; from 1.27.0 before 1.27.3; from 1.28.0 before 1.28.1; from 1.29.0 before 1.29.1 — fixed in 1.26.7, 1.27.3, 1.28.1, 1.29.1
How to fix
Upgrade to a fixed version: envoyproxy envoy 1.26.7, 1.27.3, 1.28.1, 1.29.1. Check the vendor advisory for mitigations.
References
- https://github.com/envoyproxy/envoy/commit/63895ea8e3cca9c5d3ab4c5c128ed1369969d54a
- https://github.com/envoyproxy/envoy/security/advisories/GHSA-4h5x-x9vh-m29j
- https://github.com/envoyproxy/envoy/commit/63895ea8e3cca9c5d3ab4c5c128ed1369969d54a
- https://github.com/envoyproxy/envoy/security/advisories/GHSA-4h5x-x9vh-m29j
Get alerted when CVE-2024-23327 or the next vulnerability affects your stack