What’s Vulnerable › Vulnerabilities
CVE-2024-23328: The Dataease datasource exists deserialization and arbitrary file read vulnerability
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-02-29 · updated 2026-06-17
- Weakness: CWE-502
Description
Dataease is an open source data visualization analysis tool. A deserialization vulnerability exists in the DataEase datasource, which can be exploited to execute arbitrary code. The location of the vulnerability code is `core/core-backend/src/main/java/io/dataease/datasource/type/Mysql.java.` The blacklist of mysql jdbc attacks can be bypassed and attackers can further exploit it for deserialized execution or reading arbitrary files. This vulnerability is patched in 1.18.15 and 2.3.0.
Affected products
- dataease: before 1.18.15; from 2.0.0 before 2.3.0 — fixed in 1.18.15, 2.3.0
How to fix
Upgrade to a fixed version: dataease 1.18.15, 2.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/dataease/dataease/commit/4128adf5fc4592b55fa1722a53b178967545d46a
- https://github.com/dataease/dataease/commit/bb540e6dc83df106ac3253f331066129a7487d1a
- https://github.com/dataease/dataease/security/advisories/GHSA-8x8q-p622-jf25
- https://github.com/dataease/dataease/commit/4128adf5fc4592b55fa1722a53b178967545d46a
- https://github.com/dataease/dataease/commit/bb540e6dc83df106ac3253f331066129a7487d1a
- https://github.com/dataease/dataease/security/advisories/GHSA-8x8q-p622-jf25
Get alerted when CVE-2024-23328 or the next vulnerability affects your stack