What’s Vulnerable › Vulnerabilities
CVE-2024-23349: Apache Answer: XSS vulnerability when submitting summary
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-22 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Answer.This issue affects Apache Answer: through 1.2.1. XSS attack when user enters summary. A logged-in user, when modifying their own submitted question, can input malicious code in the summary to create such an attack. Users are recommended to upgrade to version [1.2.5], which fixes the issue.
Affected products
- Apache Software Foundation Apache Answer: through 1.2.1
References
- http://www.openwall.com/lists/oss-security/2024/02/22/2
- https://lists.apache.org/thread/y5902t09vfgy7892z3vzr1zq900sgyqg
- http://www.openwall.com/lists/oss-security/2024/02/22/2
- https://lists.apache.org/thread/y5902t09vfgy7892z3vzr1zq900sgyqg
Get alerted when CVE-2024-23349 or the next vulnerability affects your stack